using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<tr[^>]*>((?!<\/tr>|<td>|<\/td>).)*<\/tr>";
string input = @"<tr asdf>
<td>
<hello>
</td>
</tr>
<tr asdf>
</tr>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}