import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<tr[^>]*>((?!<\\/tr>|<td>|<\\/td>).)*<\\/tr>";
final String string = "<tr asdf>\n"
+ "<td>\n"
+ "<hello>\n"
+ "</td>\n"
+ "</tr>\n"
+ "<tr asdf>\n"
+ "</tr>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}