using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((([.A-Z0-9!#$%&'*+/=?^_`{|}~-])+@([.A-Z0-9!#$%&'*+/=?^_`{|}~-])+\.[A-Z]{2,13})((,\s)?))";
string input = @"asd@asd.qwe, asdqwe@asd.qwe, asd@asd.qwe, ";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}