import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((([.A-Z0-9!#$%&'*+/=?^_`\\{|\\}~-])+@([.A-Z0-9!#$%&'*+/=?^_`\\{|\\}~-])+\\.[A-Z]{2,13})((,\\s)?))";
final String string = "asd@asd.qwe, asdqwe@asd.qwe, asd@asd.qwe, ";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}