// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)((([.A-Z0-9!#$%&'*+/=?^_`{|}~-])+@([.A-Z0-9!#$%&'*+/=?^_`{|}~-])+\.[A-Z]{2,13})((,\s)?))").unwrap();
let string = "asd@asd.qwe, asdqwe@asd.qwe, asd@asd.qwe, ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}