re = /((([.A-Z0-9!#$%&'*+\/=?^_`{|}~-])+@([.A-Z0-9!#$%&'*+\/=?^_`{|}~-])+\.[A-Z]{2,13})((,\s)?))/i
str = 'asd@asd.qwe, asdqwe@asd.qwe, asd@asd.qwe, '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end