import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:([\\s\\d\\x2e]*[^\\s\\d\\x2e\\x3a]+[\\x2e\\s\\d]*)|(?:[^\\s\\d\\x2e\\x3a]+[\\s\\d\\x2e]*)[^\\s\\d\\x2e\\x3a]+)[\\r\\n]";
final String string = " 512345.0a222aas22asas22asd2asdfasdf2asdfasdfasd222222aaaaafdasdfasdf222asdfasdf32asdfasdf\n"
+ "Content-Length: 0aasd2as\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}