import Foundation
// WARNING: You included a flag that Swift doesn't support: U
// When this flag is set, it inverts the "greediness" of the quantifiers so that they are not greedy by default, but become greedy if followed by '?'.
// As an alternative, this effect can also be achieved by setting a (?U) modifier setting within the pattern or by a question mark behind a quantifier (e.g. .*?).
let pattern = #"(?:([\s\d\x2e]*[^\s\d\x2e\x3a]+[\x2e\s\d]*)|(?:[^\s\d\x2e\x3a]+[\s\d\x2e]*)[^\s\d\x2e\x3a]+)[\r\n]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
512345.0a222aas22asas22asd2asdfasdf2asdfasdfasd222222aaaaafdasdfasdf222asdfasdf32asdfasdf
Content-Length: 0aasd2as
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}