import re
regex = re.compile(r"(?:([\s\d\x2e]*[^\s\d\x2e\x3a]+[\x2e\s\d]*)|(?:[^\s\d\x2e\x3a]+[\s\d\x2e]*)[^\s\d\x2e\x3a]+)[\r\n]", flags=re.IGNORECASE)
test_str = (" 512345.0a222aas22asas22asd2asdfasdf2asdfasdfasd222222aaaaafdasdfasdf222asdfasdf32asdfasdf\n"
"Content-Length: 0aasd2as\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")