re = /(?:([\s\d\x2e]*[^\s\d\x2e\x3a]+[\x2e\s\d]*)|(?:[^\s\d\x2e\x3a]+[\s\d\x2e]*)[^\s\d\x2e\x3a]+)[\r\n]/i
str = ' 512345.0a222aas22asas22asd2asdfasdf2asdfasdfasd222222aaaaafdasdfasdf222asdfasdf32asdfasdf
Content-Length: 0aasd2as
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end