const regex = /(?:([\s\d\x2e]*[^\s\d\x2e\x3a]+[\x2e\s\d]*)|(?:[^\s\d\x2e\x3a]+[\s\d\x2e]*)[^\s\d\x2e\x3a]+)[\r\n]/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:([\\s\\d\\x2e]*[^\\s\\d\\x2e\\x3a]+[\\x2e\\s\\d]*)|(?:[^\\s\\d\\x2e\\x3a]+[\\s\\d\\x2e]*)[^\\s\\d\\x2e\\x3a]+)[\\r\\n]', 'i')
const str = ` 512345.0a222aas22asas22asd2asdfasdf2asdfasdfasd222222aaaaafdasdfasdf222asdfasdf32asdfasdf
Content-Length: 0aasd2as
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}