#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!0+\.0+$)\d{1,3}(?:,\d{3})*\.\d{2}$"
Local $sString = "1,100.00" & @CRLF & _
"0.00" & @CRLF & _
"0.11" & @CRLF & _
"0.01" & @CRLF & _
"1.11" & @CRLF & _
"1.457" & @CRLF & _
"2345656.45" & @CRLF & _
"23,345,345.45"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")