import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!0+\\.0+$)\\d{1,3}(?:,\\d{3})*\\.\\d{2}$";
final String string = "1,100.00\n"
+ "0.00\n"
+ "0.11\n"
+ "0.01\n"
+ "1.11\n"
+ "1.457\n"
+ "2345656.45\n"
+ "23,345,345.45";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}