const regex = /^(?!0+\.0+$)\d{1,3}(?:,\d{3})*\.\d{2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!0+\\.0+$)\\d{1,3}(?:,\\d{3})*\\.\\d{2}$', 'gm')
const str = `1,100.00
0.00
0.11
0.01
1.11
1.457
2345656.45
23,345,345.45`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}