using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!0+\.0+$)\d{1,3}(?:,\d{3})*\.\d{2}$";
string input = @"1,100.00
0.00
0.11
0.01
1.11
1.457
2345656.45
23,345,345.45";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}