use strict;
my $str = '1,100.00
0.00
0.11
0.01
1.11
1.457
2345656.45
23,345,345.45';
my $regex = qr/^(?!0+\.0+$)\d{1,3}(?:,\d{3})*\.\d{2}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}