package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{5})-?\d{4}$`)
var str = `12345-1234`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}