$re = '/^(\d{5})-?\d{4}$/m';
$str = '12345-1234';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;