import re
regex = re.compile(r"^(\d{5})-?\d{4}$", flags=re.MULTILINE)
test_str = "12345-1234"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)