const regex = new RegExp('^(\\d{5})-?\\d{4}$', 'gm')
const str = `12345-1234`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);