using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?)\s*\b([A-Za-z]*[a-z][A-Za-z]*\b.*)";
string input = @"WORD WORD Cccc cccc cccc cccc CCCCC cccc.....
WORD Cccc cccc cccc cccc CCCCC cccc....";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}