// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*?)\s*\b([A-Za-z]*[a-z][A-Za-z]*\b.*)").unwrap();
let string = "WORD WORD Cccc cccc cccc cccc CCCCC cccc.....
WORD Cccc cccc cccc cccc CCCCC cccc....";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}