package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?)\s*\b([A-Za-z]*[a-z][A-Za-z]*\b.*)`)
var str = `WORD WORD Cccc cccc cccc cccc CCCCC cccc.....
WORD Cccc cccc cccc cccc CCCCC cccc....`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}