use strict;
my $str = 'WORD WORD Cccc cccc cccc cccc CCCCC cccc.....
WORD Cccc cccc cccc cccc CCCCC cccc....';
my $regex = qr/^(.*?)\s*\b([A-Za-z]*[a-z][A-Za-z]*\b.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}