using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)(?:_)(?![\s\S]*\1)";
string input = @"http://images.1256_120*75
http://images.123456_120*75
http://images.784217_120*75
http://images.784217_120*75
http://images.78317_120*75
http://images.784217_120*75
http://images.78217_120*75
http://images.12456_120*75
http://images.12456_120*75
http://images.784217_120*75
http://images.784217_120*75
http://images.783217_120*75
http://images.784217_120*75
http://images.784217_120*75";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}