const regex = /(\d+)(?:_)(?![\s\S]*\1)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)(?:_)(?![\\s\\S]*\\1)', 'gm')
const str = `http://images.1256_120*75
http://images.123456_120*75
http://images.784217_120*75
http://images.784217_120*75
http://images.78317_120*75
http://images.784217_120*75
http://images.78217_120*75
http://images.12456_120*75
http://images.12456_120*75
http://images.784217_120*75
http://images.784217_120*75
http://images.783217_120*75
http://images.784217_120*75
http://images.784217_120*75`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}