import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)(?:_)(?![\\s\\S]*\\1)";
final String string = "http://images.1256_120*75 \n"
+ "http://images.123456_120*75\n"
+ "http://images.784217_120*75\n"
+ "http://images.784217_120*75\n"
+ "http://images.78317_120*75\n"
+ "http://images.784217_120*75\n"
+ "http://images.78217_120*75\n"
+ "http://images.12456_120*75 \n"
+ "http://images.12456_120*75\n"
+ "http://images.784217_120*75\n"
+ "http://images.784217_120*75\n"
+ "http://images.783217_120*75\n"
+ "http://images.784217_120*75\n"
+ "http://images.784217_120*75";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}