$re = '/(\d+)(?:_)(?![\s\S]*\1)/m';
$str = 'http://images.1256_120*75
http://images.123456_120*75
http://images.784217_120*75
http://images.784217_120*75
http://images.78317_120*75
http://images.784217_120*75
http://images.78217_120*75
http://images.12456_120*75
http://images.12456_120*75
http://images.784217_120*75
http://images.784217_120*75
http://images.783217_120*75
http://images.784217_120*75
http://images.784217_120*75';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);