import Foundation
let pattern = #"(\d+)(?:_)(?![\s\S]*\1)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://images.1256_120*75
http://images.123456_120*75
http://images.784217_120*75
http://images.784217_120*75
http://images.78317_120*75
http://images.784217_120*75
http://images.78217_120*75
http://images.12456_120*75
http://images.12456_120*75
http://images.784217_120*75
http://images.784217_120*75
http://images.783217_120*75
http://images.784217_120*75
http://images.784217_120*75
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)