use strict;
my $str = 'probably yes
yes';
my $regex = qr/(?<!probably )yes/mp;
my $subst = 'probably yes';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";