re = /(?<!probably )yes/m
str = 'probably yes
yes'
subst = 'probably yes'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result