import Foundation
let pattern = #"(?<!probably )yes"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
probably yes
yes
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"probably yes"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)