import re
regex = re.compile(r"(?<!probably )yes", flags=re.MULTILINE)
test_str = ("probably yes\n"
"yes")
subst = "probably yes"
result = regex.sub(subst, test_str)
if result:
print(result)