#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[^\r\n\t\f]*error"
Local $sString = "src/client/application/shared/modals/settings/settings-model.ts(79,21): error TS2403: Subsequent variable declarations must have the same type. Variable 'obj' must be of type 'ISettingsValue', but here has type 'any'." & @CRLF & _
"src/client/application/shared/modals/settings/settings-model.ts(86,25): error TS2339: Property 'values' does not exist on type 'ISettingsValue'." & @CRLF & _
"src/client/application/shared/modals/settings/settings-model.ts(87,25): error TS2339: Property 'values' does not exist on type 'ISettingsValue'." & @CRLF & _
"src/client/application/shared/modals/settings/settings-model.ts(152,24): error TS7006: Parameter 'value' implicitly has an 'any' type." & @CRLF & _
"src/client/application/ui-cdv/dashboard/adsa.ts(6,19): error TS2304: Cannot find name 'html'." & @CRLF & _
"src/client/application/ui-cdv/dashboard/adsa.ts(10,1): error TS1148: Cannot compile modules unless the '--module' flag is provided."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")