$re = '/[^\r\n\t\f]*error/';
$str = 'src/client/application/shared/modals/settings/settings-model.ts(79,21): error TS2403: Subsequent variable declarations must have the same type. Variable \'obj\' must be of type \'ISettingsValue\', but here has type \'any\'.
src/client/application/shared/modals/settings/settings-model.ts(86,25): error TS2339: Property \'values\' does not exist on type \'ISettingsValue\'.
src/client/application/shared/modals/settings/settings-model.ts(87,25): error TS2339: Property \'values\' does not exist on type \'ISettingsValue\'.
src/client/application/shared/modals/settings/settings-model.ts(152,24): error TS7006: Parameter \'value\' implicitly has an \'any\' type.
src/client/application/ui-cdv/dashboard/adsa.ts(6,19): error TS2304: Cannot find name \'html\'.
src/client/application/ui-cdv/dashboard/adsa.ts(10,1): error TS1148: Cannot compile modules unless the \'--module\' flag is provided.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);