import re
regex = re.compile(r"[^\r\n\t\f]*error")
test_str = ("src/client/application/shared/modals/settings/settings-model.ts(79,21): error TS2403: Subsequent variable declarations must have the same type. Variable 'obj' must be of type 'ISettingsValue', but here has type 'any'.\n"
"src/client/application/shared/modals/settings/settings-model.ts(86,25): error TS2339: Property 'values' does not exist on type 'ISettingsValue'.\n"
"src/client/application/shared/modals/settings/settings-model.ts(87,25): error TS2339: Property 'values' does not exist on type 'ISettingsValue'.\n"
"src/client/application/shared/modals/settings/settings-model.ts(152,24): error TS7006: Parameter 'value' implicitly has an 'any' type.\n"
"src/client/application/ui-cdv/dashboard/adsa.ts(6,19): error TS2304: Cannot find name 'html'.\n"
"src/client/application/ui-cdv/dashboard/adsa.ts(10,1): error TS1148: Cannot compile modules unless the '--module' flag is provided.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")