import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\r\\n\\t\\f]*error";
final String string = "src/client/application/shared/modals/settings/settings-model.ts(79,21): error TS2403: Subsequent variable declarations must have the same type. Variable 'obj' must be of type 'ISettingsValue', but here has type 'any'.\n"
+ "src/client/application/shared/modals/settings/settings-model.ts(86,25): error TS2339: Property 'values' does not exist on type 'ISettingsValue'.\n"
+ "src/client/application/shared/modals/settings/settings-model.ts(87,25): error TS2339: Property 'values' does not exist on type 'ISettingsValue'.\n"
+ "src/client/application/shared/modals/settings/settings-model.ts(152,24): error TS7006: Parameter 'value' implicitly has an 'any' type.\n"
+ "src/client/application/ui-cdv/dashboard/adsa.ts(6,19): error TS2304: Cannot find name 'html'.\n"
+ "src/client/application/ui-cdv/dashboard/adsa.ts(10,1): error TS1148: Cannot compile modules unless the '--module' flag is provided.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}