// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^\r\n\t\f]*error").unwrap();
let string = "src/client/application/shared/modals/settings/settings-model.ts(79,21): error TS2403: Subsequent variable declarations must have the same type. Variable 'obj' must be of type 'ISettingsValue', but here has type 'any'.
src/client/application/shared/modals/settings/settings-model.ts(86,25): error TS2339: Property 'values' does not exist on type 'ISettingsValue'.
src/client/application/shared/modals/settings/settings-model.ts(87,25): error TS2339: Property 'values' does not exist on type 'ISettingsValue'.
src/client/application/shared/modals/settings/settings-model.ts(152,24): error TS7006: Parameter 'value' implicitly has an 'any' type.
src/client/application/ui-cdv/dashboard/adsa.ts(6,19): error TS2304: Cannot find name 'html'.
src/client/application/ui-cdv/dashboard/adsa.ts(10,1): error TS1148: Cannot compile modules unless the '--module' flag is provided.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}