#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\/[^\/]+\/[^\/]+)(\/.*)$"
Local $sString = "/leisure/venuename/news" & @CRLF & _
"/leisure/venuename/page/384" & @CRLF & _
""
Local $sSubst = "$1#$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)