re = /^(\/[^\/]+\/[^\/]+)(\/.*)$/m
str = '/leisure/venuename/news
/leisure/venuename/page/384
'
subst = '$1#$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result