using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\/[^\/]+\/[^\/]+)(\/.*)$";
string substitution = @"$1#$2";
string input = @"/leisure/venuename/news
/leisure/venuename/page/384
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}