$re = '/^(\/[^\/]+\/[^\/]+)(\/.*)$/m';
$str = '/leisure/venuename/news
/leisure/venuename/page/384
';
$subst = "$1#$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;