use strict;
my $str = '/leisure/venuename/news
/leisure/venuename/page/384
';
my $regex = qr/^(\/[^\/]+\/[^\/]+)(\/.*)$/mp;
my $subst = '$1#$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";