#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^a-zA-Z0-9]*"
Local $sString = "*******toto-rererere--------*********"
Local $sSubst = "azea"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)