const regex = /[^a-zA-Z0-9]*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^a-zA-Z0-9]*', '')
const str = `*******toto-rererere--------*********`;
const subst = `azea`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);