re = /[^a-zA-Z0-9]*/
str = '*******toto-rererere--------*********'
subst = 'azea'
result = str.sub(re, subst)
# Print the result of the substitution
puts result