use strict;
my $str = '*******toto-rererere--------*********';
my $regex = qr/[^a-zA-Z0-9]*/p;
my $subst = 'azea';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";