using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"e([bngr][odbp]?[poy]){2}";
string input = @"ebony
enoby
ebondy
eboby
egogy
ebory
enobby
enopby
enony";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}