re = /e([bngr][odbp]?[poy]){2}/i
str = 'ebony
enoby
ebondy
eboby
egogy
ebory
enobby
enopby
enony'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end