package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)e([bngr][odbp]?[poy]){2}`)
var str = `ebony
enoby
ebondy
eboby
egogy
ebory
enobby
enopby
enony`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}